Networks Training

  • About
  • My Books
  • SUGGESTED TRAINING
  • HOME
  • Cisco Networking
    • Cisco General
    • Cisco IOS
    • Cisco VPN
    • Cisco Wireless
  • Cisco ASA
    • Cisco ASA General
    • Cisco ASA Firewall Configuration
  • Certifications Training
    • CCNA Training
    • Cisco Certifications
    • I.T Training
  • General
    • General Networking
    • IP Telephony
    • Network Security
    • Product Reviews
    • Software
  • Cisco Routers
  • Cisco Switches
You are here: Home / Cisco Routers / WAN Redundancy with two ISPs using static floating default routes

WAN Redundancy with two ISPs using static floating default routes

Written By Harris Andrea

In today’s networks, WAN redundancy is very important even in small networks. To have a truly redundant WAN connectivity, you must use two different ISP connections.

However, there is a catch here. You need to use BGP dynamic routing protocol (usually), which adds some complexity and extra requirements.

In most cases, you will need two dedicated IPv4 network subnets. The biggest problem you will encounter is that IPv4 addresses have been depleted since 31 January 2011 and the few blocks available for sale are very expensive.

However, there is an alternative and cheaper solution. If you don’t require a whole public subnet, you can have primary and backup WAN connections and use NAT for both links with automatic fail over.

This scenario however will work only for networks having outbound traffic (i.e only traffic from inside LAN towards the Internet).

In the following example I will show you such a connection topology that will prove useful in many network scenarios.

Note: You can still use a BGP connection with each of the providers announcing a default route, but usually it comes with a fee. In this topology we will use two floating static default routes.

Table of Contents

    • Network Scenario
    • Equipment Used
    • Router Configuration
  • DOWNLOAD ARTICLE AS PDF FILE
  • Related Posts
MORE READING:  Is router uptime a measure of stability or insecurity ?

Network Scenario

In the diagram below, we have two WAN connections (ISP1 main connection and ISP2 Backup connection). We just need to provide Internet access for the internal LAN subnet.

wan redundancy 2 isp

Equipment Used

We are using a dual wan Cisco 891-k9 router with IOS c880data-universalk9-mz.153-3.M2.bin

Router Configuration

Configuration of the interfaces

interface GigabitEthernet0
description Internet_ISP1_Main
ip address 10.10.10.10 255.255.255.0
no ip proxy-arp
ip nat outside   <—— enables NAT on this interface

interface FastEthernet8
description Internet_ISP2_Back-up
ip address 100.100.100.100 255.255.255.0
no ip proxy-arp
ip nat outside   <—— enables NAT on this interface

interface Vlan1
description Local_Area_Network
ip address 192.168.1.1 255.255.255.0
ip nat inside   <—— traffic generated within this interfaces will be nated

Configure the ACL that matches the LAN network

ip access-list extended NAT_LAN
permit ip 192.168.1.0 0.0.0.255 any

Configure the route maps that will select which traffic will be NATed for each WAN interface

route-map NAT_ISP1_Main permit 10
match ip address NAT_LAN   <——- Matches the ACL configured to match the LAN network
match interface GigabitEthernet0 <—– Matches the specific WAN interface
!

route-map NAT_ISP2_Back-up permit 10
match ip address NAT_LAN   <——— Matches the ACL configured to match the LAN network
match interface FastEthernet8     <—– Matches the specific WAN interface

Configure an IP SLA responder and tracking

MORE READING:  How to Configure DHCP on Cisco 851 or 871 Router

ip sla 1
 icmp-echo 8.8.8.8  source-interface GigabitEthernet0  <——  Pings google DNS using the specific interface
frequency 30                            <——   Ping’s are sent at 30s intervals
ip sla schedule 1 life forever start-time now
   <—— The SLA responder is activated and will never stop

track 1 ip sla 1                        <——-  A track object is created using IPSLA1

Add the default routes


ip route 0.0.0.0 0.0.0.0 10.10.10.1 track 1
ip route 0.0.0.0 0.0.0.0 100.100.100.1 30

As long as track 1 object is Up, the first route will be installed in the routing table. If track 1 changes state to down then the route will be removed from the routing table (floating route) and the second default route with metric 30 will be installed in the routing table.

Enable NAT

ip nat inside source route-map NAT_ISP1_Main  interface GigabitEthernet0  overload
ip nat inside source route-map NAT_ISP2_Back-up interface FastEthernet8   overload

This a simple, cheap and easy method to have automatic fail over for your internet connection.

For more reading on failover and redundancy examples, see this is post here for HSRP with object tracking.

DOWNLOAD ARTICLE AS PDF FILE

Related Posts

  • How to Configure a Loopback Interface on Cisco Router & Switch
  • Comparison of Static vs Dynamic Routing in TCP/IP Networks
  • Cisco OSPF DR-BDR Election in Broadcast Networks – Configuration Example
  • How to Configure Port Forwarding on Cisco Router (With Examples)
  • Adjusting MSS and MTU on Cisco 800 routers for PPPoE over DSL

Filed Under: Cisco Routers

Download Free Cisco Commands Cheat Sheets

Enter your Email below to Download our Free Cisco Commands Cheat Sheets for Routers, Switches and ASA Firewalls.

We use Elastic Email as our marketing automation service. By submitting this form, you agree that the information you provide will be transferred to Elastic Email for processing in accordance with their Terms of Use and Privacy Policy. Also, you allow me to send you informational and marketing emails from time-to-time.

About Harris Andrea

Harris Andrea is an Engineer with more than two decades of professional experience in the fields of TCP/IP Networks, Information Security and I.T. Over the years he has acquired several professional certifications such as CCNA, CCNP, CEH, ECSA etc.

He is a self-published author of two books ("Cisco ASA Firewall Fundamentals" and "Cisco VPN Configuration Guide") which are available at Amazon and on this website as well.

Comments

  1. Ali says

    May 14, 2015 at 11:18 am

    Thank you for the awesome tutorial, I have setup something like this a few times. I have always used a static route for the tracked IP to prevent flapping. I like the idea of specifying the source interface under ip sla though.
    ip route 8.8.8.8 255.255.255.255 10.10.10.1

  2. sahir says

    May 14, 2015 at 1:12 pm

    Hi Andrea, great article, is there is any way were we can download the article in a pdf format? if not, can you please add the option to all of your articles ?

    Thanks for sharing

  3. Harris Andrea says

    May 14, 2015 at 4:27 pm

    Thanks for your comment and feedback Ali.
    I’m glad you liked the article.

    Harris

  4. Harris Andrea says

    May 14, 2015 at 4:29 pm

    Hi Sahir,
    Currently I don’t have the option to download the article as PDF. I will look into it and maybe implement it in new articles.

    Have a good day
    Harris

  5. Beka says

    March 21, 2018 at 10:36 am

    hello, thx u for this tutorial.
    with this scenario what will happen for VPNs? NAT? do they need duplicate for another second backup ip?
    sorry for my bad english.

  6. Harris Andrea says

    March 21, 2018 at 11:52 am

    This scenario works well only for outgoing traffic. If you have incoming traffic (i.e traffic initiated from Internet and you have VPN or webserver hosted on your network) then you need other redundancy options like BGP, Load Balancer etc.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Search this site

About Networks Training

We Provide Technical Tutorials and Configuration Examples about TCP/IP Networks with focus on Cisco Products and Technologies. This blog entails my own thoughts and ideas, which may not represent the thoughts of Cisco Systems Inc. This blog is NOT affiliated or endorsed by Cisco Systems Inc. All product names, logos and artwork are copyrights/trademarks of their respective owners.

Amazon Disclosure

As an Amazon Associate I earn from qualifying purchases.
Amazon and the Amazon logo are trademarks of Amazon.com, Inc. or its affiliates.

Search

BLOGROLL

Tech21Century
Firewall.cx

Copyright © 2023 | Privacy Policy | Terms and Conditions | Hire Me | Contact | Amazon Disclaimer | Delivery Policy

12 shares