Networks Training

  • About
  • My Books
  • SUGGESTED TRAINING
  • HOME
  • Cisco Networking
    • Cisco General
    • Cisco IOS
    • Cisco VPN
    • Cisco Wireless
  • Cisco ASA
    • Cisco ASA General
    • Cisco ASA Firewall Configuration
  • Certifications Training
    • CCNA Training
    • Cisco Certifications
    • I.T Training
  • General
    • General Networking
    • IP Telephony
    • Network Security
    • Product Reviews
    • Software
  • Cisco Routers
  • Cisco Switches
You are here: Home / Cisco ASA Firewall Configuration / Cisco ASA Firewall with PPPoE (Configuration Example on 5505)

Cisco ASA Firewall with PPPoE (Configuration Example on 5505)

Written By Harris Andrea

A Cisco ASA Firewall is ideal for Broadband access connectivity to the Internet since it provides state of the art and solid network security protection.

Especially for small business or home use, the ASA 5505 model is ideal for broadband ADSL access connectivity.

Some ISPs provide Point to Point over Ethernet access, which is abbreviated as PPPoE. Cisco ASA 5500 series support the PPPoE protocol as we can see below.

cisco asa pppoe internet access

On the Figure above we assume the following:

  • The Internal IP address range is 192.168.1.0 /24
  • There is a modem in front of the Firewall connected to the ISP
  • The ISP provides a public address to the ASA via PPPoE
  • The ASA connects to the modem with Ethernet 0/0 (E0/0)
  • The ASA connects to the internal network with Ethernet 0/1 (E0/1)
  • There is NAT performed on the ASA to translate internal private addresses to the ISP Provided public address
  • The ASA acts as a DHCP server to provide 32 addresses to the internal hosts.

Here is the sample configuration example on 5505:

ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password * encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group ATT
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd * encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list inside_access_out extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1492
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
! for the following nat commands see note at the end
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
access-group inside_access_out in interface inside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group ATT request dialout pppoe
vpdn group ATT localname [ENTER ISP USERNAME HERE]
vpdn group ATT ppp authentication chap [or PAP, depends on your ISP settings]
vpdn username [ENTER ISP USERNAME HERE] password [ENTER ISP PASSWORD HERE]
dhcpd auto_config outside
!
dhcpd address 192.168.1.1-192.168.1.32 inside
dhcpd dns [ENTER ISP DNS ADDRESS HERE] interface inside
dhcpd enable inside
!

MORE READING:  Prevent Spoofing Attacks on Cisco ASA using RPF

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
————————————————————————————-

Please remember to configure the Outside MTU to 1492 since there is an extra 8-bytes overhead used by PPPoE.

EDIT: For ASA version 8.3 and later

From ASA version after 8.3 the NAT commands are changed as following:

object network obj_any
subnet 0.0.0.0 0.0.0.0
nat (inside,outside) dynamic interface

 

Related Posts

  • Prevent Spoofing Attacks on Cisco ASA using RPF
  • Configuring Connection Limits on Cisco ASA Firewalls – Protect from DoS
  • Configuring AAA Authentication-Authorization-Accounting on Cisco ASA Firewall (TACACS+, RADIUS)
  • Cisco ASA Firewall Management Interface Configuration (with Example)
  • How to Configure Access Control Lists on a Cisco ASA 5500/5500-X Firewall (with Examples)

Filed Under: Cisco ASA Firewall Configuration

Download Free Cisco Commands Cheat Sheets

Enter your Email below to Download our Free Cisco Commands Cheat Sheets for Routers, Switches and ASA Firewalls.

We use Elastic Email as our marketing automation service. By submitting this form, you agree that the information you provide will be transferred to Elastic Email for processing in accordance with their Terms of Use and Privacy Policy. Also, you allow me to send you informational and marketing emails from time-to-time.

About Harris Andrea

Harris Andrea is an Engineer with more than two decades of professional experience in the fields of TCP/IP Networks, Information Security and I.T. Over the years he has acquired several professional certifications such as CCNA, CCNP, CEH, ECSA etc.

He is a self-published author of two books ("Cisco ASA Firewall Fundamentals" and "Cisco VPN Configuration Guide") which are available at Amazon and on this website as well.

Comments

  1. David says

    June 9, 2010 at 3:10 pm

    and if our ISP provide a public IP (80.1.1.2), mask (255.255.255.0) and gateway (80.1.1.1)?

    Thanks.

  2. Blog Admin says

    June 9, 2010 at 4:07 pm

    Hello David,

    If your ISP provides you with a static public IP, then you need to configure it on interface vlan2 and remove the command “ip address pppoe setroute”.

    So, the configuration for interface vlan 2 will be:

    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group ATT
    ip address 80.1.1.2 255.255.255.0

    Now, to set the default gateway, do the following:

    route outside 0.0.0.0 0.0.0.0 80.1.1.1

  3. sdf says

    March 10, 2011 at 1:15 pm

    Is there necessary “dhcpd auto_config outside”??
    PPPoE is not supported in conjunction with DHCP because with PPPoE the IP address is assigned by PPP…

  4. Blog Admin says

    March 10, 2011 at 4:25 pm

    You can remove “dhcpd auto_config outside” .

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Search this site

About Networks Training

We Provide Technical Tutorials and Configuration Examples about TCP/IP Networks with focus on Cisco Products and Technologies. This blog entails my own thoughts and ideas, which may not represent the thoughts of Cisco Systems Inc. This blog is NOT affiliated or endorsed by Cisco Systems Inc. All product names, logos and artwork are copyrights/trademarks of their respective owners.

Amazon Disclosure

As an Amazon Associate I earn from qualifying purchases.
Amazon and the Amazon logo are trademarks of Amazon.com, Inc. or its affiliates.

Search

BLOGROLL

Tech21Century
Firewall.cx

Copyright © 2023 | Privacy Policy | Terms and Conditions | Hire Me | Contact | Amazon Disclaimer | Delivery Policy

0 shares