The most common scenario for big enterprise networks with multiple routers is to have a single IGP routing protocol (IGP = Interior Gateway Protocol) running between the routers in order to distribute all the routing information of the network.
The most common IGP routing protocols used by today’s networks are OSPF, EIGRP (Cisco proprietary) and in some cases IS-IS. RIP also is an IGP but is not used anymore. It is found only in old legacy networks (or in lab environments for study purposes).
The above situation of having a single routing protocol is the most common case. However, there are networks that use two different IGP protocols for various reasons (such as merge of two companies that use different routing protocols, migration from one protocol to another, installation of router devices from a different vendor etc).
If you have two IGP routing protocols in the same network, then you must perform Routing Redistribution in order to exchange routing information between the two protocols.
Note that you can configure and enable two routing protocols on a router (e.g both OSPF and EIGRP). However, this is not enough to exchange information between the two routing protocols. You must configure Redistribution as well.
The tutorial below will focus on Routing Redistribution between OSPF and EIGRP and vice-versa. As the title says, this is an introductory tutorial in order to learn the basics of router redistribution. The network topology shown below is very basic but it will help you to expand the concepts in bigger networks.
Network Scenario
From the topology above, assume we have a remote enterprise network (RED) running EIGRP only on router “Ent_Remote”. Also, we have another enterprise network (BLUE) with two routers (ENT1 and ENT2). ENT1 is running OSPF only and ENT2 is running both OSPF and EIGRP.
Our goal is to have all router devices learn all the routes from both networks. That is, we want to redistribute the routes of “Ent_Remote” into the routing table of router “ENT1” (which is running only OSPF) and vice-versa.
This scenario is often seen in real life when two companies merge and they have to converge without causing downtime or modifications to the networks.
Company BLUE is running OSPF and has the following networks: 10.10.0.0/24 & 10.10.100.0/24 behind router ENT2 and 172.16.1.0/24 and 172.16.100.0/24 behind ENT1.
Company RED (running EIGRP) has merged with BLUE and has networks 192.168.1.0/24 and 192.168.100.0/24 behind router “ENT_remote”
(The networks are emulated using loopbacks.)
Redistribution Configuration
NOTE: You can find the full router configurations at the end of this tutorial.
First, let’s see the routing table on ENT1 before the redistribution:
C 1.1.1.0/30 is directly connected, FastEthernet4
L 1.1.1.1/32 is directly connected, FastEthernet4
10.0.0.0/32 is subnetted, 2 subnets
O 10.10.0.1 [110/2] via 1.1.1.2, 02:25:53, FastEthernet4
O 10.10.100.1 [110/2] via 1.1.1.2, 02:25:53, FastEthernet4
172.16.0.0/16 is variably subnetted, 4 subnets, 2 masksC 172.16.1.0/24 is directly connected, Loopback1
L 172.16.1.1/32 is directly connected, Loopback1
C 172.16.100.0/24 is directly connected, Loopback100
L 172.16.100.1/32 is directly connected, Loopback100
From the routing table above (before redistribution), currently there are routes for the local networks emulated by loopbacks 1&100 and also two routes learned via OSPF for the networks behind ENT2. (The blue color routes above denoted by “O” are learned via OSPF).
Now, let’s see the routing table of ENT2 before the redistribution
This router is the junction between the two networks and runs both OSPF and EIGRP. Therefore, its routing table contains the routes from both networks. However, we have not configured Redistribution yet.
ENT2#sh ip routeCodes: C – connected, D – EIGRP, O – OSPF,
1.0.0.0/30 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, FastEthernet1
2.0.0.0/30 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, FastEthernet0
172.16.0.0/32 is subnetted, 2 subnets
O 172.16.1.1 [110/2] via 1.1.1.1, 02:38:35, FastEthernet1
O 172.16.100.1 [110/2] via 1.1.1.1, 02:40:11, FastEthernet1
10.0.0.0/24 is subnetted, 2 subnets
C 10.10.0.0 is directly connected, Loopback0
C 10.10.100.0 is directly connected, Loopback100
D 192.168.1.0/24 [90/156160] via 2.2.2.2, 00:00:06, FastEthernet0
D 192.168.100.0/24 [90/156160] via 2.2.2.2, 00:00:06, FastEthernet0
The blue color routes denoted by “O” are learned via OSPF (from the BLUE network) and are received from the neighbor router ENT1. The red color routes denoted by “D” are learned via EIGRP and are received from the RED network (from “Ent_Remote”).
Let’s examine the “ENT_Remote” routing table:
C 2.2.2.0/30 is directly connected, GigabitEthernet0
L 2.2.2.2/32 is directly connected, GigabitEthernet0
10.0.0.0/24 is subnetted, 2 subnets
D 10.10.0.0 [90/156160] via 2.2.2.1, 00:06:11, GigabitEthernet0
D 10.10.100.0 [90/156160] via 2.2.2.1, 00:06:11, GigabitEthernet0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Loopback1
L 192.168.1.1/32 is directly connected, Loopback1
192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.100.0/24 is directly connected, Loopback100
L 192.168.100.1/32 is directly connected, Loopback100
The ENT_Remote device above has only EIGRP routes received from ENT2.
Our goal is to have a full converged network and every router needs to learn the routes to all the other networks. To achieve this, redistribution must be performed on ENT2 router that runs both protocols.
Redistribute OSPF into EIGRP
When redistributing routes from other IGP’s into EIGRP you have to keep in mind that you must specify the metric for the redistributed routes which can be done in two ways:
1) OPTION1: Specify default metric for all the routes and issue redistribution command. All the routes that are redistributed will have that default metric.
ENT2 Router
redistribute ospf 1 < —–Redistribute OSPF into EIGRP
network 2.2.2.0 0.0.0.3
network 10.10.0.0 0.0.0.255
network 10.10.100.0 0.0.0.255
default-metric 1000 33 255 1 1500 < — Set the default metric for all redistributed routes
no auto-summary
eigrp router-id 2.2.2.1
2) OPTION2: Set the metric per each redistribute command
ENT2 Router
redistribute ospf 1 metric 1000 33 255 1 1500 <- Set the metric for the specific OSPF 1 instance
network 2.2.2.0 0.0.0.3
network 10.10.0.0 0.0.0.255
network 10.10.100.0 0.0.0.255
no auto-summary
eigrp router-id 2.2.2.1
NOTE:
metric 1000 33 255 1 1500 – This command sets the K values that compose the metric
bandwidth to 1000 (Kbps), the delay to 33(tens-of-microseconds, or 330 microseconds), reliability to 255 (a value between 1–255 ,255 is best), load to 1 (a value between 1–255, 1 is best), and MTU of 1500.
The routing table on router “Ent_Remote” has the redistributed OSPF routes shown as
D EX (EIGRP external) as shown below.
Ent_Remote#sh ip route eigrp
1.0.0.0/30 is subnetted, 1 subnets
D EX 1.1.1.0 [170/2571008] via 2.2.2.1, 00:01:29, GigabitEthernet0
10.0.0.0/24 is subnetted, 2 subnets
D 10.10.0.0 [90/156160] via 2.2.2.1, 00:01:29, GigabitEthernet0
D 10.10.100.0 [90/156160] via 2.2.2.1, 00:01:29, GigabitEthernet0
172.16.0.0/32 is subnetted, 2 subnets
D EX 172.16.1.1 [170/2571008] via 2.2.2.1, 00:01:29, GigabitEthernet0
D EX 172.16.100.1 [170/2571008] via 2.2.2.1, 00:01:29, GigabitEthernet0
Redistribute EIGRP into OSPF
Basic redistribution into OSPF is pretty simple, just remember the word subnets because if you issue the redistribution command without the subnets statement you will only redistribute classful routes. Again the redistribution must be done on ENT2 router that has both protocols.
ENT2 Router
router ospf 1 < —-First go into OSPF routing instance
router-id 1.1.1.2
log-adjacency-changes
redistribute eigrp 1 subnets < —- Redistribute EIGRP into OSPF
network 1.1.1.0 0.0.0.3 area 0
network 10.10.0.0 0.0.255.255 area 0
Now, the routing table on ENT1 shows the EIGRP redistributed routes as E2 with a metric of 20
2.0.0.0/30 is subnetted, 1 subnets
O E2 2.2.2.0 [110/20] via 1.1.1.2, 00:00:08, FastEthernet4
10.0.0.0/32 is subnetted, 2 subnets
O 10.10.0.1 [110/2] via 1.1.1.2, 00:00:08, FastEthernet4
O 10.10.100.1 [110/2] via 1.1.1.2, 00:00:08, FastEthernet4
O E2 192.168.1.0/24 [110/20] via 1.1.1.2, 00:00:08, FastEthernet4
O E2 192.168.100.0/24 [110/20] via 1.1.1.2, 00:00:08, FastEthernet4
To verify that the remote EIGRP network is reachable you can issue a ping or a traceroute
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 msENT1#traceroute 192.168.1.1Type escape sequence to abort.
Tracing the route to 192.168.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 1.1.1.2 0 msec 0 msec 0 msec
2 2.2.2.2 0 msec 0 msec *
192.168.1.1 0 msec 0 msec
Known via “ospf 1”, distance 110, metric 20, type extern 2, forward metric 1
Last update from 1.1.1.2 on FastEthernet4, 00:07:23 ago
Routing Descriptor Blocks:
* 1.1.1.2, from 1.1.1.2, 00:07:23 ago, via FastEthernet4
Route metric is 20, traffic share count is 1
DOWNLOAD ARTICLE AS PDF FILE
DOWNLOAD FULL ROUTER CONFIGURATIONS
Related Posts
- How to Configure a Loopback Interface on Cisco Router & Switch
- Comparison of Static vs Dynamic Routing in TCP/IP Networks
- Cisco OSPF DR-BDR Election in Broadcast Networks – Configuration Example
- How to Configure Port Forwarding on Cisco Router (With Examples)
- Adjusting MSS and MTU on Cisco 800 routers for PPPoE over DSL